Global Micro Solutions
Hosted Exchange - Users receiving password pop up messagesOperational

Components

Hosted Exchange 2016, Hosted Exchange 2019

Locations

Teraco West - Data Centre 2, Teraco East - Data Centre 1



March 17, 2025 9:31AM SAST
[Investigating] ISSUE: Some users are experiencing password pop up messages while attempting to connect to Outlook via the mail application. CUSTOMER IMPACT: Customers may not be able to connect to their emails via the mail application. WORKAROUND: Customer's can use the Outlook Web Access (mail.dotnetwork2.co.za/owa) to access their emails.

March 20, 2025 6:38AM SAST
[Monitoring] All reported issue has been resolved. We are currently still monitoring.

Back to current status